Wednesday, April 18, 2012

Ruby gem 'churn' dependency conflict solution

The main reason of writing this solution is that I haven't found any solution regarding this problem by searching till date.

Just wanted to run some sample test scripts to explore ruby gem "churn".

Installed 'churn-0.0.15', latest map gem 'map-5.1.0' and as churn required gem main so installed latest 'main.5.0.'. But gem 'main' required 'map' version '4.3.0', so I had installed that too.
Finally when I tried to run sample script, it gave me the following error
"Unable to activate churn-0.0.15, because map-5.1.0 conflicts with map (= 4.3.0) (Gem::LoadError)"
So, map 4.3.0 was conflicting with map 5.1.0, though in order to install 'churn' I had to install both of them.

Probable Solution:
I need to install only one 'map' gem which will satisfy both churn and  main.

I uninstalled churn, map and main, all versions.

Then I installed 'map-4.3.0' then 'main-4.6.0' and finally "churn-0.0.15'.

It solved the conflict that I was having.

Similar Issues:

No comments: